Архив за день: 04.02.2021



DaVinci: Ошибка при запуске программы

Открываю проект в DaVinci Resolve 16.2.8, он открывается, но появляется окошко с сообщением об ошибке:

The GPU failed to perform image processing because of an error.
Error Code: 209.

 

Накануне я обновил DaVinci Resolve. Скорее всего из неё обрали поддержку CUDA (в моём случае минимум Compute Capability of 3.0).
Посмотрел логи:
«C:\Users\Denis\AppData\Roaming\Blackmagic Design\DaVinci Resolve\Support\logs\ResolveDebug.txt»
Там была такая запись:

[0x0000323c] | GPUManager           | INFO  | 2021-02-04 13:33:04,843 | Flushing GPU memory...
[0x0000323c] | DVIP                 | ERROR | 2021-02-04 13:33:04,845 | C:/jenkins/workspace/dvip/DaVinciIP/DaVinciIP/Unpacker/Unpacker_kernel.cu:226: CUDA error cudaErrorNoKernelImageForDevice (209)
[0x0000323c] | GPUManager           | ERROR | 2021-02-04 13:33:04,851 | Exception caught while running GPU algorithms:
[0x0000323c] | DVIP                 | ERROR | 2021-02-04 13:33:04,851 | 
DVIP Exception: At position C:/jenkins/workspace/dvip/DaVinciIP/DaVinciIP/Unpacker/Unpacker_kernel.cu:226
 - API: CUDA
 - API Error Code: cudaErrorNoKernelImageForDevice (209)

Как всегда для решения подобной проблемы у пользователя аж 3 варианта:
1. Купить видео-карту помощнее
2. Установить старую версию DaVinci (16.2.6)
3. Переключить режим работы программы на OpenCL:
SettingsMemory & GPUGPU Configuration
GPU Processing Mode = OpenCL

Придётся воспользоваться вторым вариантом, т.к. вариант (3) почему-то замедляет производительность программы (судя по некоторым отзывам, хотя по идее не должен), а тратить деньги на новую видюху я не хочу. К тому же сейчас из-за ажиотажа вокруг майнинга криптовалют, видео-карты стоят нереальных денег.
Текущий драйвер NVIDIA GeForce: 461.40.
Попробовал драйверы:
461.09 — проблема не решилась
460.89 — аналогично
460.79 — та же ошибка при открытии проекта
457.61 — увы
457.30 — не сработало
457.09 — ошибка осталась
456.71 — нет
456.55 — тоже нет
456.38 — и этот драйвер не сработал.

Таким образом рекомендация с форума, в которой предлагалось попробовать старый драйвер, мне не помогла.

Зато проблема решилась установкой версии 16.2.6.005